Support Center > Knowledgebase > Plesk > Upgrade fails with the "Failed to check whether a new license key is available" error.
Upgrade fails with the "Failed to check whether a new license key is available" error.
Symptoms:
I run upgrade using Autoinstaller but it stops with the error, even if the license is up to dated:
ERROR: Failed to check whether a new license key is available. The installation will not continue.
Cause:
The problem appears with Autoinstaller 3.3.0 that was released with the very first build of Plesk 8.3.0 version. It has been fixed in the next autoinstaller 3.3.0 build, that may be downloaded from Plesk 8.3.0 download page.
Resolution:
Download fresh autoinstaller (build is equal or greater then v3.3.0 build071228.14) that corresponds to your OS version and replace /usr/local/psa/admin/sbin/autoinstaller and /usr/local/psa/bin/autoinstaller files with new one
For example for CentOS 5 i386:
# wget http://download1.swsoft.com/Plesk/Plesk8.3/CentOS5/swsoft_installer_v3.3.0_build080116.12_os_CentOS_5_i386
# cp swsoft_installer_v3.3.0_build080116.12_os_CentOS_5_i386 /usr/local/psa/bin/autoinstaller
# cp swsoft_installer_v3.3.0_build080116.12_os_CentOS_5_i386 /usr/local/psa/admin/sbin/autoinstaller
# chmod 755 /usr/local/psa/admin/sbin/autoinstaller /usr/local/psa/bin/autoinstaller
# chown root:root /usr/local/psa/admin/sbin/autoinstaller /usr/local/psa/bin/autoinstaller
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